ID #1075

I am running an older version of OS X. Will the pedias work?

The latest version of the Pedias will only work with OS X 10.4.9 (Tiger) and above. 

Tags: -

Related entries:

You cannot comment on this entry