IMDB ID lost when importing XBMC .nfo file

Report your bugs here - if someone else has already mentioned the same bug, just add on to their post with as much info as possible to make the hunting easier.

IMDB ID lost when importing XBMC .nfo file

Postby riconster » Tue Jun 02, 2020 11:22 am

Hi,

When I import a folder that contains a video file and an XBMC .nfo file, the IMDB field is not imported.

My .nfo file contains this entry:
Code: Select all
     <id moviedb = "IMDb"> tt0252117 </id>


And only if it is modified recognizes it:
Code: Select all
     <id> tt0252117 </id>


Obviously I cannot modify all my .nfo files so I am writing to ask for a solution to be able to import the IMDB ID without modifying the text structure of my .nfo file (which is created with the ViMediaManager program on Mac).

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<movie>
    <title>¡Ay, qué tiempos señor don Simón!</title>
    <sorttitle>¡Ay, qué tiempos señor don Simón!</sorttitle>
    <originaltitle>¡Ay, qué tiempos señor don Simón!</originaltitle>
    <id moviedb="IMDb">tt0034417</id>
    <id moviedb="TMDB">294384</id>
    <year>1941</year>
    <releasedate>1941-09-19</releasedate>
    <rating>7.2</rating>
    <votes>62</votes>
    <outline>A not very grief stricken young widow flutters her hand fan between a dashing young soldier and an elderly politician in this Belle Epoque era musical comedy...</outline>
    <plot>A not very grief stricken young widow flutters her hand fan between a dashing young soldier and an elderly politician in this Belle Epoque era musical comedy.</plot>
    <runtime>102</runtime>
    <genre>Romance</genre>
    <genre>Comedy</genre>
    <genre>Music</genre>
    <genre>Musical</genre>
    <language code="">Español</language>
    <language code="">Spanish</language>
    <studio>Films Mundiales</studio>
    <studios>
        <studio>Films Mundiales</studio>
    </studios>
    <country>Mexico</country>
    <director>Julio Bracho</director>
    <credits>Julio Bracho, Neftali Beltrán</credits>
    <camera>Gabriel Figueroa</camera>
    <sound>Raúl Lavista</sound>
    <starring>
        <star>Joaquín Pardavé</star>
        <star>Arturo de Córdova</star>
        <star>Mapy Cortés</star>
    </starring>
    <thumb>¡Ay,.qué.tiempos.señor.don.Simón!.(1941).480p.H264.AAC.English.tbn</thumb>
    <fileinfo>
        <streamdetails>
            <video>
                <codec>H264</codec>
                <width>596</width>
                <height>480</height>
                <aspect>1.24</aspect>
                <duration>103</duration>
                <durationinseconds>6151</durationinseconds>
                <scantype>Progressive</scantype>
                <bitdepth>8</bitdepth>
            </video>
            <audio>
                <codec>AAC</codec>
                <channels>2</channels>
                <language code="en">English</language>
            </audio>
        </streamdetails>
    </fileinfo>
</movie>


I would also like to know how I could import the information from an .nfo file even if there is no video file. When I try it only imports the name of the .nfo file and not its content. There must be a video file next to the .nfo file in order to import the information, but I would like to import the data even if there is no video file.

Hopefully it can be resolved. Thank you!
riconster
Junior Member
Junior Member
 
Posts: 4
Joined: Sat Apr 16, 2011 11:37 am

Re: IMDB ID lost when importing XBMC .nfo file

Postby riconster » Tue Jul 07, 2020 9:46 pm

Hi Conor,

Could you help me to solve this problem?

A month has passed and I still have no answer.

Sorry for the inconvenience.

I hope you can help me.

Thank you.
:P
riconster
Junior Member
Junior Member
 
Posts: 4
Joined: Sat Apr 16, 2011 11:37 am


Return to Bug Reports

cron